Social Engineer Toolkit工具连接Metasploit错误解决办法

Social Engineer Toolkit ,顾名思义,社会工程学工具。提供一些功能:

  • 大批量邮件发送,附带漏洞附件。
  • 可以搭配ettercap等进行dns欺骗+网站克隆(比如我们克隆一个facebook的登录口,dns投毒之后用户访问facebook就是访问我们的服务器,账号密码自然也是发到我们这边)。
  • U盘病毒
  • 等等

Social Engineer Toolkit搭配Metasploit的,才让这个工具显得更强大。
BT5自带的SET不能用,所以自己研究了很久,找了国外各种官方资料,视频,现在放出解决方案:
在/pentest/exploit目录下,安装SET,shell中运行:

安装完之后,进入set目录运行

这样就可以使用SET的一些基本功能,比如克隆网站。但是有些功能需要metasploit支持的时候就会报错。

这个其实不是SET的错误,而是我们metasploit的,我们需要再metasploit的目录下进行一些ruby依赖包的安装更新。
由于某些依赖包要求ruby版本>1.9.2,而BT的默认ruby版本是 1.9.2的,所以我们不得不升级ruby到1.9.3(测试过2.0.0p0版本,metasploit不兼容)

安装 rvm
rvm是管理升级ruby的一个很强大,方便的工具
用rvm官方推荐的方式安装

RVM已经安装到/ust/local/rvm/下,此路径需记住,后面需要,本人已安装过,所以才有提示rvm exists

应该请把这句话加在$HOME/.bash_profile文件中,以便在开启一个终端会话时候加载RVM

升级ruby 查看当前RVM中已经安装的ruby版本。我的是已经安装好了的 – -安装很简单只需要查看一下然后安装就好了。

这里可以看到多个版本,我推荐还是装1.9.3的 因为本人之前装的2.0.0-p0 然后在msf3目录下运行msf会错误

安装命令file:///C:UsersADMINI~1AppDataLocalTempABA3681AFD6F4349B85E1EF264F3C88F.pngrvm install 1.9.3 可以自己直接复制版本号过来然后把1.9.3版本设置为缺省

如果报错,那就运行

再执行一次

然后在exit退出,重启电脑

之后可以查看一下ruby的版本:

上面的步骤都完成之后了,我们就可以更新依赖包了:

这样我们用SET连接Metasploit的没有问题啦。

91ri.org小编语:此错误解决方法是作者花费大量时间实验整理的,在此感谢作者提供的解决方案。

link:http://bbs.blackbap.org/forum.php?mod=viewthread&tid=4236&extra=page%3D1%26filter%3Dauthor%26orderby%3Ddateline%26orderby%3Ddateline

本文由网络安全攻防研究室(www.91ri.org)信息安全小组收集整理,转载请注明出处。